Archlinux

Plasma next 5.3

Después de un tiempo finalmente me he decidido a probar lo nuevo de kde, y he de decir que estoy profundamente decepcionado. Mucho se hablo en su momento de los grandes problemas de kde4 cuando salió, y poco se ha hablado del nuevo, por que sí, ha vuelto a pasar, este nuevo sistema de escritorio es un desastre total. Después de todo el problema que hubo con kde4 y las más que merecidas críticas que tuvo este entorno de escritorio, se vuelve a repetir la tragedia, esperemos que como paso en kde4 también mejore en la versión 4.

Las caídas de plasma son constantes (empiezo a sospechar que algo tiene que ver con el controlador nouveau, pero no estoy seguro), y ha veces se hace inaguantable viéndote forzado a reiniciar, parece ser que son las aplicaciones de kde4(muchas aun), las que provocan más caídas de plasma, y seamos sinceros tener un entorno de escritorio que esta constantemente reiniciándose, con lo cual perdiendo barra y todos los complementos, no es nada agradable.

error_kde

Por si fuera poco, el servicio automático para enviar errores sigue sin funcionar, si, a mi nunca me funciono en kde4. Si ha eso le sumamos fallos en los componentes principales, tenemos un desastre total, y es que hay algunos defectillos menores, pero que no dejan de mermar la experiencia de usuario. Entre ellos esta krunner que aunque cumple bien su función, a veces es difícil sacarlo con el acceso directo, al menos si tienes varios monitores, por que se la sopla el escritorio principal y sale donde el escritorio cree que esta el foco, o no sale directamente. Luego está el tema de la bandeja de notificaciones y aplicaciones, que integra solo los programas que ve oportunos, dejándote por ejemplo sin la opción de restablecer steam desde ella, o mostrándote el menú desplegable encima de ella dejándote si opción de hacer click en otros iconos.

bandeja_sonidobandeja_sonido_fail

 

 

 

 

 

 

Desde luego es bonito, y el aspecto visual ha sido cuidado, pero carece de muchos plasmoides que para mi son importantes, por ejemplo el controlador de kde-connect. De hecho y a pesar de que en kdeconnect se encuentra en mi distribución instalado por defecto, solo se puede controlar por terminal, y ni si quiera activa un demonio por defecto. Bien puede ser un problema de la distribución que no instala lo necesario, pero a mi parecer la falta del plasmoide, que no se puede encontrar en la tienda tampoco es crítica. Pero bueno, esta claro que la mayoría puede vivir sin esta característica.

Sin duda alguna plasma next tiene futuro, y no todas las cosas son malas, además con el tiempo se corregirán los errores y con suerte se conseguirá un entorno tan estable como kde 4.14 ,pero ese futuro aun no ha llegado. Ni que decir que hay muchos fallos más, pero estos son los que me más me molestan personalmente. Y SI se puede usar, pero si por casualidad estás usando kde 4.14, se más listo que yo y no te pase a plasma next, no te pierdes tanto como para sacrificar la estabilidad de tu sistema.

Usando: manjaro 8.13.1.

Anuncios

Integración gtk en kde para archlinux

Si bien kde tiene un conjunto de aplicaciones excelente que abarca todos los campos, es posible que gente como yo que ha usado toda su vida gtk se sientan cojos y tengan la necesidad de usar algunas aplicaciones gtk (principalmente navegadores). La cuestión es que las aplicaciones gtk se ven fatal por defecto en kde. La solución instalar unos añadidos al decorador de ventanas que utilicemos, en mi caso oxigen.

sudo pacman -S oxygen-gtk2 oxygen-gtk3

En caso de que quieras usar qtcurve:

sudo pacman -S qtcurve-gtk2 qtcurve-kde4

qt-firefox-integracion

Una muestra de como queda firefox con la integración de oxigen.

El enlance olvidado de qt4

Hace unos cuantos meses si mal no recuerdo, en archlinux, se realizó la sustitución completa de qt, por qt4. Si bien en el momento, tenía problemas para actualizar lo resolví des-instalando primero qt, y todo fue bien hasta hace poco. Quería instalar QJoyPad, una aplicación para controlar el teclado con el gamepad. Por desgracia esta aplicación requería de qt, el cual yo había borrado. Pues bien esto podría pasar con cualquier aplicación que use qt (antigua), pero el remedio es simple. Se trata de crear un enlace simbólico, para que cuando se llame a qmake el sistema use qmake-qt4.

sudo ln -s /usr/bin/qmake-qt4 /usr/bin/qmake

The root device is not configured to be mounted

Hace poco, ocurrió un pequeño error en archlinux que pareció afectar a bastante gente, entre ellos estaba yo. El error es el que se muestra en el título, y aunque en la mayoría de los casos fue un warning , que aparecía en el log de inicio, para algunos trajo consecuencias. Pues bien, tiene fácil solución; esta relacionado con el cargador de arranque por lo que dependiendo del que uses se corrige de una forma u otra:

-Grub:

Basta con actualizar el grub con el siguiente comando.

grub-mkconfig -o /boot/grub/grub.cfg

-Syslinux:

El cargador que yo uso, y por desgracia me costo más encontrar solución, ya que es menos usado. No obstante basta con editar el archivo de configuración de Syslinux.

sudo nano /boot/syslinux/syslinux.cfg

En la linea que pone algo siminar a (la x varia) “APPEND root=/dev/sdax ro” de tu distribución (arch en este caso) y cambiar “ro” por “rw”. Quedaría algo así.

APPEND root=/dev/sdax rw

Bajar la versión del kernel en Archlinux

Por desgracia, la última vez que actualicé mi sistema archlinux, tuve algunos problemas, como que no me apagaba ni suspendía el sistema. Pero estas cosas pasan con cualquier sistema. Me puse a indagar para encontrar una solución y al poco, caí en la cuenta de que podía deberse a la nueva versión del kernel (3.9.xx). La solución, cambiar a la versión antigua del kernel. La forma de hacerlo:

1- Encontrar la versión del kernel que vas a instalar, lo mas sencillo es que no la hayas eliminado de la caché por lo que encontrarás el paquete en /var/cache/pacman/pkg , o descargar la versión desde una página adecuada a tu distribución. Aunque si eres masoquista siempre puede descargarlo y compilarlo desde la página oficial de linux.

2- Instalarlo en el sistema, este caso es para archlinux, pero cada gestor de paquetes te da la opción de una forma u otra de instalar desde archivo.

sudo pacman -U /var/cache/pacman/pkg/linux-3.8.11-1-x86_64.pkg.tar.xz

Por supuesto este es el caso de que lo tengas en caché, en otro caso deberías poner la ruta completa del archivo. Si no puedes encontrar un kernel, en archlinux siempre tienes la opción de instalar la versión lts (linux-lts).